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Methods of Inserting and Deleting Worksheets
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By default, new blank Excel 2021 workbooks 
contain one worksheet. But you can add up to as 
many worksheets as your system's RAM 
(memory) will support. Likewise, if you don't 
need all of the worksheets you've added to a 
workbook, you can delete any you aren't using. 
You can also change the default number of 
worksheets Excel will include in new, blank 
workbooks.

INSERT/DELETE OPTION DESCRIPTION
Selecting the New 
sheet button

This inserts a new worksheet to the right of 
the selected worksheet in a workbook. 
Alternatively, you can use 
the Shift+F11 keyboard shortcut to insert a 
new worksheet to the left of the selected 
worksheet.

Right-clicking any worksheet 
tab and then selecting Insert

This opens the Insert dialog box 
with Worksheet automatically selected. 
From here, you can simply select OK to 
insert a new worksheet to the left of the 
worksheet you right-clicked.

Using the Insert ribbon 
command

On the Home tab, select the drop-down 
arrow on the Insert button and then 
select Insert Sheet to insert a worksheet 
immediately to the left of the currently 
selected worksheet.

Right-clicking a worksheet 
tab, and then selecting Delete

This deletes the worksheet tab you right-
clicked.

Using the Delete ribbon 
command

On the Home tab, selecting the drop-down 
arrow on the Delete button and then 
selecting Delete Sheet deletes the currently 
selected worksheet.



Tab Formatting Options
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By default, worksheet tabs in Excel 2021 appear with generic sheet names, such 
as Sheet1, Sheet2, Sheet3, and in the default gray user interface (UI) color scheme. As you 
add more and more worksheets to a workbook, it's easy to see how this could become 
difficult to navigate. You may wonder if your critical sales data is 
on Sheet11 or Sheet12 and, if you don't format your worksheet tabs, you'll have no visual 
cues to help you out. This is why Excel 2021 provides you with a number of options for 
formatting your worksheet tabs. The most basic of these are the options to rename your 
worksheets and to change the color of worksheet tabs. You can access the commands for 
doing either of these by right-clicking the desired worksheet tab.



Methods of Repositioning Worksheets
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Excel 2021 provides you with two methods for repositioning your worksheets. The first 
method is to simply drag the desired worksheet tab or tabs to the desired new location. 
When you use this method, the tabs you're moving appear as small file icons and Excel 
displays a black location marker that indicates where the tabs will be located when you 
drop them in place. To use this method to move more than one worksheet simultaneously, 
you must first group the worksheets. You can drag worksheets to a different location in the 
same workbook or into any other open Excel workbook.

The second method for repositioning worksheets is to use the Move or Copy dialog box. 
You can use this dialog box to reposition worksheets within the same workbook, move 
worksheets to another open workbook, or create a new workbook into which you can 
place existing worksheets. You also have the option of making a copy of a worksheet to 
paste to another location, an option not available when you drag worksheets into place. 
However, you can move only one worksheet at a time when using the Move or 
Copy dialog box. You can access the dialog box either by right-clicking any worksheet tab 
and then selecting Move or Copy, or by selecting Home → Format → Move or Copy 
Sheet.



Methods of Repositioning Worksheets
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MOVE OR COPY DIALOG 
BOX ELEMENT DESCRIPTION

To book drop-down list Use this to select the workbook you want to 
move the selected worksheet to. By default, 
this is set to the currently selected workbook. 
You can also choose to create a new workbook 
as the destination for the existing worksheet.

Before sheet list Select where to position the worksheet you're 
moving. Excel will place the relocated 
worksheet to the left of the worksheet you 
select here.

Create a copy check box Check this check box to copy and paste the 
worksheet instead of moving it from one 
location to another.



The Hide and Unhide Worksheets Options
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If you need to work with or display only some of the worksheets 
in your workbooks, you can choose to hide the worksheets you 
don't want to see. This can be especially helpful when working in 
workbooks that contain numerous worksheets or when you need 
to display a workbook that contains sensitive information not 
meant for all audiences. Like hidden columns and rows, hidden 
worksheets retain their data, and formulas and functions can still 
reference their cells.

You can access the commands for hiding and unhiding Excel 
worksheets either by right-clicking the worksheet tabs or by 
selecting
Home → Format → Hide & Unhide. 

Selecting the Hide or Hide Sheet command, respectively, will 
hide all currently selected worksheets. Selecting the Unhide or 
the Unhide Sheet command opens a dialog box, which enables 
you to unhide only one worksheet at a time.
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Custom Views
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You've already encountered Excel's preconfigured workbook views: Normal, Page Break Preview, 
and Page Layout. But if none of these quite suits your needs, you can create a custom view. Custom 
views save all of your print settings along with any display settings you have currently applied to a 
worksheet. Custom views are worksheet-specific, so you'll have to create them for each worksheet 
in a workbook. You can create multiple custom views for each worksheet.
Custom views retain the following display and print settings: cell and column dimensions, hidden 
rows and columns, cell and range selections, page layout, print areas, margins, and headers and 
footers.
All custom views you have saved for a particular worksheet will be displayed in the Custom 
Views dialog box. From here, you can opt to create new custom views, delete existing custom 
views, or apply a custom view to the currently selected worksheet. You can access the dialog box 
by selecting View → Custom Views.



The Add View Dialog Box
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When you select the Add button in the Custom Views dialog box, Excel displays a dialog 
box, which you can use to create and save new custom views. The Add View dialog box 
enables you to name your custom views and to decide whether or not to include print 
settings or hidden rows, columns, and filter settings in your custom views.



The Split Command
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• Split command in Excel lets you view multiple sections of the same worksheet at once. 
• You can divide the view into two panes (vertical or horizontal) or four panes. 
• Split bars can be dragged to adjust pane sizes, each with its own scroll bar for independent 

navigation. 
• Access via View → Split. 
• If you select a row or column header before splitting, the worksheet divides into two panes. 
• If you select a cell, the worksheet divides into four panes (above and to the left of the cell). 



The Freeze Panes Options
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The Freeze Panes feature in Excel 2021 is 
designed to keep specific rows or columns 
visible while you scroll through large 
worksheets. This ensures that important labels, 
such as column headers or row identifiers, 
remain on screen, making it easier to interpret 
data and avoid mistakes during entry or analysis. 
You can access this function through View → 
Freeze Panes, where Excel offers several 
options: freezing both rows above and columns 
to the left of a selected cell, freezing just the top 
row, or freezing only the first column. These 
settings are applied individually to each 
worksheet, giving you flexibility to customize the 
view depending on the layout of your data. In 
short, Freeze Panes helps maintain context 
while navigating complex spreadsheets, much 
like printing labels on every page ensures clarity 
in hard copies.



The Freeze Panes Options
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Freeze Panes Option Description

Freeze Panes
Freezes all rows above and all columns to the left of the 
currently selected cell. Use this option to keep both row 
and column labels in view at all times.

Freeze Top Row Freezes the top row of the currently selected worksheet.

Freeze First Column Freezes the first column of the currently selected 
worksheet.

Unfreeze Panes
Unfreezes all cells on the currently selected worksheet. This 
option appears only once you've frozen panes on the 
worksheet.



The Arrange All Command
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The Arrange All command provides you with a number of options for arranging multiple 
workbooks on screen simultaneously, depending on your particular needs.

You can access the Arrange All command by selecting View → Arrange All.



The Arrange Windows Dialog Box
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You can select the desired view option for the Arrange All command in the Arrange 
Windows dialog box. Selecting the Arrange All command automatically displays the 
Arrange Windows dialog box, which provides you with four display options.

Some of the display options affect your ability to immediately access particular UI 
elements, such as the ribbon.



The Arrange Windows Dialog Box
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Option Displays Open Workbook Windows

Tiled In rows and columns, with an even amount of space allotted to each 
workbook window, depending on the number of open workbooks.

Horizontal
One on top of the other, with each window taking up the full amount of 
horizontal space. Excel divides the vertical space evenly depending on the 
number of open workbooks.

Vertical
Side by side, with each window taking up the full amount of vertical space. 
Excel divides the horizontal space evenly, depending on the number of 
open workbooks.

Cascade

In an offset stack, with just enough of the title bar for each workbook 
window in view so you can select the workbook you'd like to bring to the 
front. In this view, the workbook windows do not automatically adjust 
when you select windows from the back. So, you may need to rearrange 
the windows manually to view subsequent workbooks.



The View Side by Side Command
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The View Side by Side command in Excel allows you to compare two different workbooks 
simultaneously. It works like a blend of the Split and Arrange All commands, giving you a 
side-by-side view for easier comparison. 
If more than two workbooks are open, 
Excel prompts you to choose which one 
to compare with the active workbook. 
By default, scrolling is synchronized 
between the two worksheets, so you 
can move through them together. This 
synchronization can be toggled on or 
off using the Synchronous Scrolling 
command, giving you flexibility 
depending on how you want to review 
the data.



The Switch Windows Command
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The Switch Windows command enables you to easily switch among multiple open 
workbooks. This way, you can change which open workbook you want to view without 
having to minimize or manually arrange your workbook windows. This feature can be 
helpful when you select the Cascade option in the Arrange Windows dialog box, but works 
with any Excel view. You can access the Switch Windows command in the Window group 
on the View tab.



The New Window Command
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The New Window command in Excel lets you open another instance of the same workbook so you can work 
in different sections simultaneously. This is especially useful when paired with Arrange All or View Side by 
Side, as it allows you to organize multiple views of the workbook for easier navigation and comparison. Each 
new instance is labeled with the workbook name followed by a colon and a sequential number, distinguishing 
the windows. Importantly, any changes made in one window are reflected across all instances, since they are 
linked to the same original file, and all edits are saved back into that file.



Workspaces
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In prior versions of Excel, because separate workbooks all opened within the same instance 
of the Excel UI, users were able to save multiple workbook arrangements as a workspace. 
Workspaces enabled users to save a particular configuration or arrangement of workbook 
windows as a workspace file. Although you can no longer save a workspace file in Excel 
2021, you can open workspace files created in previous versions of Excel. When you open a 
workspace file, Excel automatically opens all workbooks saved in the workspace and 
arranges the workbook windows exactly as they were configured. This saves you the time 
and effort of opening multiple files and then rearranging them to be able to work as you 
need to. Workspaces can include multiple workbook files and they can contain multiple 
instances of the same workbook window opened by using the New Window command. 
The file format for Excel workspaces is the XLW format.

You must have access to the original workbook files that are included in a workspace file in 
order to open and view the workspace.
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Workbook Properties
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Workbook properties in Excel are pieces of information about a workbook file, also known 
as metadata. They help identify details such as who created the file, when it was created, 
when it was last modified, and its current status. Properties can also include tags, which 
are short keywords or descriptions that make files easier to locate in searches—for 
example, a sales workbook might be tagged with terms like territories, department, 
quarter, or commission. Some properties, like creation and modification dates, file size, and 
location, are generated automatically by Excel. Others, such as tags and categories, are 
user-defined. Additionally, Excel 2021 allows you to create custom properties tailored to 
your organization’s needs, making it easier to manage and identify workbooks across a 
network or directory.



Workbook Properties in the Backstage View
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Perhaps the simplest and most direct way to view and modify your 
workbook properties is on the Info tab of the Backstage view. When 
you select the Info tab, some of the most common document 
properties appear in the right pane. Some of these are 
automatically created, saved, and updated by Excel, and others can 
be modified. Properties that you can change here appear as text 
boxes when you place your pointer over the property value.
The Show All Properties link at the bottom of the right pane 
expands the view of workbook properties in the Backstage view so 
you can view and modify more of them. Once expanded, you can 
select the Show Fewer Properties link to collapse the view back to 
its default state.



The Properties Dialog Box
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If you want to view all of the document properties for your 
workbook or create custom document properties, you can 
open the Properties dialog box. The dialog box is divided into 
five tabs that enable you to work with all properties 
associated with the current workbook.

To open it, select File → Info, select the Properties drop-down 
arrow in the right pane, and then select Advanced Properties.
The Properties dialog box displays the file name of the 
currently selected workbook file before the word "Properties" 
in the title bar.

The following table identifies the workbook properties that 
are displayed on the various tabs in the Properties dialog box.



The Properties Dialog Box
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Properties Dialog Box Tab Contains

General

General information about the workbook file, such as the file type, the file 
size, where the file is saved, and the dates when the file was created and last 
modified. Excel creates and updates these workbook properties 
automatically.

Summary
The default document properties that you can modify. Workbook properties 
on this tab include the document title, the author, keywords, and any 
included comments.

Statistics
System-level information about the workbook file, such as when it was 
created, last accessed, last modified, and last printed. Excel creates and 
updates these properties automatically.

Contents The names of all worksheets in the document, and any named cell ranges. 
Excel creates and updates these properties automatically.

Custom The commands you will use to create custom document properties.



Custom Workbook Properties
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If you would like to create workbook properties that more 
specifically help you identify your files based on your 
organization's processes, departments, terminology, client 
list, or other standards, you can create custom workbook 
properties.

Excel 2021 includes a number of preset categories of custom 
workbook properties, or you can create an entirely unique 
property. You can also restrict the values users can enter into 
custom property fields to ensure a large number of users will 
be able to successfully search for workbook files.



Custom Workbook Properties
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Custom Tab 
Element Description

Name field If you select an existing name from the Name list, it will appear here. Or you can type a 
unique, new property name in this field.

Name list Displays a list of the preset property categories. When you select a name from this list, it 
appears in the Name field.

Type drop-down 
list

Allows you to select a content type to restrict what users can enter into your custom 
properties. You can select text, date, or number for values that can be typed into the 
property. Or you can select the Yes or no option to require users to select one of those 
two values. (This could be a useful option for properties such as "Approved" or "Review 
Complete.") 

Value field This is where you enter the value for the property.
Properties field Displays all custom properties for the workbook.

Add button

Once you've configured a new custom property, the Add button adds it to the Properties 
field. When you select an existing custom property in the Properties field, the Add button 
becomes the Modify button, which enables you to save changes to existing custom 
properties.

Delete button Deletes the selected custom property from the Properties field.
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