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Insert, Delete, and Adjust Cells, 
Columns, and Rows



The Insert and Delete Options
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Using Insert Cells or Delete Cells from the drop-down menus opens dialog boxes, giving 
options to shift cells in a chosen direction or insert/delete entire rows or columns, even if 
only part of the sheet is selected.

These commands act on whatever is selected:
• Selecting cells → Insert/Delete cells.
• Selecting a row → Insert/Delete the entire row.
• Selecting a column → Insert/Delete the entire column.

By default, Excel shifts cells to make space:
• Insert → pushes cells down or columns right.
• Delete → pulls cells up or columns left.

You can also access the Insert and Delete dialog boxes by right-clicking a selected cell or 
range, and then selecting either Insert or Delete.



Width and Height Adjustments
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When data or formulas spill beyond cell borders, you need to adjust cell sizes by changing 
row heights, column widths, or both.

Manual adjustment method:
• Place the mouse pointer over the border of a row or column header until it shows a 

dark line with a double arrow.
• Click and drag the border to resize.
• For rows → drag the bottom border of the row.
• For columns → drag the right-hand border of the column.



Width and Height Adjustments
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You can resize all columns or rows in a worksheet at the 
same time. To do this, select the Select All button 
where the column and the row headers intersect to 
select all cells in the worksheet, and then double-click 
any column or row border in the headers. 

You can also use the AutoFit feature in Excel to 
automatically adjust row height or column width to 
match cell content. You can access the AutoFit 
commands by selecting Home → Format. To use the 
AutoFit feature, select any cell or range within the 
row(s) or the column(s) that you would like to adjust 
and then select either the AutoFit Row Height or the 
AutoFit Column Width command from the Format 
drop-down menu.



Width and Height Adjustments
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Finally, you can use the Row Height and Column Width dialog boxes to adjust cell size. To 
adjust cell size by using this method, simply select a cell in the desired row, open the 
appropriate dialog box, enter the desired height or width value, and then select OK. You 
can access the Row Height and the Column Width dialog boxes by selecting either Home 
→ Format → Row Height or Home → Format → Column Width.



The Hide and Unhide Commands
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The Hide and Unhide commands enable you to suppress the visibility of particular rows or 
columns in your worksheets. These commands can come in handy in large worksheets that 
have more rows or columns than can fit on the screen at once, or if your worksheets 
contain extraneous information or calculation data that doesn't need to be displayed. 
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Search for and Replace Data



The Find Command
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You can use the Find command to locate specific content within your worksheets and 
workbooks. Excel opens the Find and Replace dialog box with the Find tab automatically 
selected. 
• To access the Find command, select Home → Find & Select → Find or press Ctrl + F
• You can direct Excel to search only within a particular range by selecting that range 

before selecting the Find command.



The Find Command
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Find Tab Element Use This To
Find what field Enter your search query. This is the content Excel will search for in the workbook or worksheet.
Options button Expand or collapse additional options in the Find and Replace dialog box.

Format indicator
Determine whether or not you have selected a particular format to search for. If you have not selected a format, 
the indicator displays the text No Format Set. If you have selected a format, the indicator displays the text 
Preview*.

Format button

Select the type of formatting you wish to search for. Selecting the Format button opens the Find Format dialog 
box, which allows you to select the type of formatting you wish to search for. Selecting the Format drop-down 
arrow also gives you the option to manually select a worksheet cell to set the desired formatting to search for or 
to clear formatting from the search query.

Within drop-down list Decide between searching the current worksheet or the entire workbook.
Search drop-down list Choose whether to search by row or by column.
Look in drop-down list Tell Excel to search within cells containing values, formulas, or comments.
Match case check box Require an exact casing match in order for Excel to return search results.
Match entire cell 
contents check box Require an exact content match within a cell in order for Excel to return a search result.

Find All button
Display a list of all instances of content matching your search query at the bottom of the Find and Replace 
dialog box. When you select a search result from the list, Excel automatically navigates to and selects the 
matching cell.

Find Next button Cycle among all cells with content matching the search query. Excel automatically navigates to and selects each 
cell containing matching content in the order it finds them.

Search results list Review search results when you use the Find All command and to select cells containing content that matches 
the search query.



The Replace Command
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As with the Find command, you can apply the Replace command for one instance of your 
search query at a time or for all matching instances at once.

• The keyboard shortcut for the Replace command is Ctrl + H.

• As with the Find command, you can 
direct the Replace command to 
search for and replace only content 
within a particular range by first 
selecting the range and then selecting 
the Replace command. Also, the Look 
in options are restricted to only 
Formulas on the Replace tab.



The Go To Dialog Box
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The Go To dialog box in Excel is a powerful navigation tool that allows you to quickly move to 
any cell within a worksheet or even across worksheets in the same workbook. By entering a 
cell reference, you can jump directly to that location, and if you need to access a cell in 
another worksheet, you simply type the worksheet name followed by an exclamation mark 
(!) before the cell reference. Unlike the Name Box, the Go To dialog box keeps a history of 
previously visited cells, making it especially useful for large worksheets where you frequently 
revisit specific cells.

You can access it through 
• Home → Find & Select → Go To 
• By pressing F5 on your keyboard.



The Go To Special Dialog Box
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The Go To Special feature in Excel is an advanced navigation 
and selection tool that lets you highlight multiple cells 
based on specific criteria, rather than just jumping to a 
single cell like the standard Go To dialog box. It’s especially 
useful in large worksheets where manually selecting cells 
with the Ctrl key would be tedious. With Go To Special, you 
can quickly find and select cells that meet conditions such 
as containing formulas, blanks, constants, or specific data 
types. Once selected, these cells behave like any normal 
range—you can format them, clear their contents, or enter 
data across them efficiently. 

This feature works only within the currently active worksheet and can be accessed through 
• Home → Find & Select → Go To Special or 
• by opening the Go To dialog box and clicking the Special button.



The Go To Special Dialog Box
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Option Select This To
Comments option Select all cells containing comments.

Constants option

Select all cells containing constants. Using the following check boxes, you can restrict the search to select only cells containing: Numbers
• Text
• Logicals—this option will not select instances of TRUE or FALSE that are the result of a logical function, only cases in which you've typed TRUE or 

FALSE as text. Also, Excel differentiates TRUE and FALSE from all other text when using this option.

Formulas option

Select cells containing formulas. Using the check boxes below, you can restrict the search to select only cells containing formulas that return: 
Numbers
• Text
• Logicals—this option will select instances of TRUE or FALSE that are the result of a logical function.
• Errors

Blanks option Select all blank cells within a dataset or a selected range.
Current region option Select all cells in the same region as the currently selected cell or range.
Current array option Select all cells in the same array as the currently selected cell or range, if the selected cell is part of an array.
Objects option Select all objects on the worksheet. This option does not select worksheet cells, only objects on the worksheet.
Row differences option Select all cells in the same row as the selected cell that do not contain the same content as the selected cell.

Column differences option Select all cells in the same column as the selected cell that do not contain the same content as the selected cell.

Precedents option
Select all cells that contain data feeding the formula in the selected cell. Direct only—select only those cells directly feeding or fed by the currently 
selected cell.
• All levels—select all cells feeding or fed by the currently selected cell. 

Dependents option
Select all cells that contain formulas that the currently selected cell is feeding. Direct only—select only those cells directly feeding or fed by the 
currently selected cell.
• All levels—all cells feeding or fed by the currently selected cell. 

Last cell option Select the last cell containing data or formatting in a worksheet.
Visible cells only option Select all non-hidden cells.

Conditional formats option
Select all cells containing conditional formatting or all cells containing the same conditional formatting as the currently selected cell. 
All—select all cells containing conditional formatting.
• Same—select only cells containing the same conditional formatting as the currently selected cell.

Data validation option
Select all cells containing data validation or all cells containing the same data validation as the currently selected cell. All—select all cells containing 
data validation.
• Same—select only cells containing the same data validation criteria as the currently selected cell.
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Use Proofing and Research Tools



The Spelling Dialog Box
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You can use the Spelling dialog box to inspect your worksheets for spelling errors.

You can access the Spelling dialog box by selecting Review → Spelling or by pressing the F7 
key. You can direct Excel to check the spelling in only a particular range by first selecting it and 
then opening the Spelling dialog box.

Unlike some other applications, such as 
Microsoft Office Word, Excel does not mark 
spelling errors with red underlines. Don't rely 
on on-screen markup to flag spelling errors in 
your worksheets. You must run the spelling 
check manually.



Spelling Dialog Box 
Option Description

Not in Dictionary field Displays the word that the spelling checker does not recognize and has flagged as a possible error.

Suggestions list Displays a list of suggested alternatives for the flagged word from the currently selected dictionary.

Dictionary language 
drop-down list Allows you to select the desired dictionary against which Excel checks for spelling errors.

Ignore Once button Ignores the currently selected instance of a misspelled word.
Ignore All button Ignores all instances of the currently selected misspelled word throughout a worksheet.

Add to Dictionary button
Adds the term in the Not in Dictionary field to the currently selected dictionary so Excel no longer flags it as a 
misspelling. The dictionary is shared by other Microsoft Office apps, so any terms you add will also be active in 
those apps.

Change button Replaces the currently selected instance of the word in the Not in Dictionary field with the word selected in the 
Suggestions list.

Change All button Replaces all instances of the word in the Not in Dictionary field throughout a worksheet with the word selected in 
the Suggestions list.

AutoCorrect button Adds the word in the Not in Dictionary field to the AutoCorrect feature so that, whenever you type the flagged 
word, Excel automatically replaces it with the word selected in the Suggestions list.

Options button Opens the Excel Options dialog box with the Proofing tab selected so you can adjust the AutoCorrect options and 
settings for correcting spellings.

Undo Last button Reverts the last corrected instance of a word back to its original spelling.
Cancel button Cancels the current spelling check and closes the Spelling dialog box.

The Spelling Dialog Box
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The AutoCorrect Feature
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Excel 2021 also includes a feature that can help you avoid spelling errors as you type them—
AutoCorrect. The AutoCorrect feature automatically changes common misspellings to the 
correct spelling as you type. For example, if you type teh in a cell, Excel will automatically 
change it to the. AutoCorrect can also automatically format text as you type it, such as 
creating a hyperlink when you type a web address or an email address, and insert certain 
mathematical symbols when you type particular keystrokes. When you install Excel 2021, 
AutoCorrect is preconfigured with a set of terms it will automatically correct, but you can 
customize this to suit your needs.



Thesaurus Task Pane Element Is Used To

Back button Navigate back to the previous term.

Synonyms await field Enter a word or a phrase you want to find synonyms, antonyms, or related terms for.

Search button Execute a search query.

Search results
Review search results, or select a particular term from the search results to perform a 
search on that term. You can also select the drop-down arrow next to a result to copy the 
term to the clipboard or insert the term into the active cell on your worksheet.

Dictionary drop-down list Select the dictionary you want the Thesaurus task pane to search.

The Thesaurus Task Pane
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Excel 2021 also includes a handy feature you can use if you 
simply want to search for synonyms, antonyms, or related 
terms for a particular word or phrase: the Thesaurus task 
pane. In the Thesaurus task pane, you have the option of 
selecting from a handful of default dictionaries that Excel 
can search to return results.

The following table describes the various elements of the 
Thesaurus task pane.



The Smart Lookup Task Pane
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Excel 2021 can also help you perform research on your 
data from several online resources. The Smart Lookup 
task pane uses the active cell's contents as a search 
query to run in Microsoft's Bing® search engine. It can 
also automatically incorporate the content of 
surrounding cells to refine the search. 
With a cell selected, you can access the Smart Lookup 
task pane by selecting Review → Smart Lookup or by 
right-clicking the cell and selecting Smart Lookup from 
the contextual menu. You can also perform a Smart 
Lookup operation by selecting the More search results 
option on any search you perform using the Search 
feature. In addition, you can search by specifying the 
search text from within the Smart Lookup task pane 
itself.
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